Blog

WordPressのビジュアルエディタがChromeでだけエラー

WordPressの3.5.2をセットアップしていて、投稿画面でビジュアルエディタが使えないという不具合がありました。

テキストに変更もできない状態です。エラーとしては

Uncaught SyntaxError: Unexpected end of input wp-tinymce.php:4
  1. Uncaught ReferenceError: tinyMCE is not defined post-new.php:1068
  1. Uncaught ReferenceError: tinyMCE is not defined
 

のようなエラーがでていました。この問題はChromeで発生しました。Firefoxでは発生しませんでした。

結論からいうと、

wp-config.phpに

を追加してください。これは、Javascriptファイルを連結するかどうかです。どうやらChromeでは、連結すると不具合があるようです。

わずかな速度の違いだと思うので、上記のようにfalseで連結しないようにすると、Chromeでもエラーがでなくなりました。

 

この情報、なぜほとんどネットにないんでしょう?

Comments are closed.